H4D changelog

in About hosting4devs, Changes

All notable changes to hosting4devs will be documented in this file:

v1.2.8 (Mar 15, 2018)
- Improve Let's Encrypt error messages - Bug fixes


v1.2.7 (Feb 28, 2018)
- Fix mixed content using NGINX with SSL in the front of Apache


v1.2.6 (Feb 27, 2018)
- Show all ips of and interface and protocol not only one


v1.2.5 (Feb 27, 2018)
- Improve nginx virtual host over ssl


v1.2.4 (Feb 26, 2018)
- Improve Let`s Encrypt challenge solver over nginx


v1.2.3 (Feb 25, 2018)
- Improve virtual host extra settings and docs


v1.2.2 (Feb 25, 2018)
- Backward compatibility to previous Apache apps


v1.2.1 (Feb 25, 2018)
- Services management improvements


v1.2.0 (Feb 25, 2018)

  • Added the ability to support multiple web servers (apache, nginx or nginx+apache)
  • NGINX + Apache stack
  • Install addons on document root
  • MariaDB support
  • Virtual host configuration improvements for better performance
  • Virtual host extra config per app
  • Bug fixes
  • UI improvements

v1.1.5 (Jan 28, 2018)

  • Modules management performance improvements

v1.1.4 (Jan 28, 2018)

  • h4dcs and packages auto-update

v1.1.3 (Jan 27, 2018)

  • PHP 7.2 support

v1.1.2 (Jan 18, 2018)

  • h4dcs sofware update improvements

v1.1.1 (Dec 30, 2017)

  • Let's Encrypt auto-renewal fixes
  • Nginx web server support
  • Log rotate improvements

v1.0.0 (Aug 8, 2017)
H4D private beta release

  • Server metrics
  • Server firewall
  • Server services management
  • Run snippets or scripts
  • Create and deploy web hosting, modern PHP apps and databases:
    • Email features:
      • Email accounts
      • Forwarders
      • Antispam rules
    • One click apps:
      • WordPress
      • ownCloud
      • phpMyAdmin
      • Rainloop
    • Install Let's Encrypt and SSL certificates
    • SSH and FTP:
      • Manage credentials
      • Manage auth mode
      • Install and manage SSH keys
    • Manage MySQL databases and users
  • Supported web server: Apache 2
  • Supported databases: MySQL
  • Supported PHP versions: 5.6, 5.6, 7 and 7.1

Comments